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1. Introduction

The purpose of this document is to provide detailed instructions for extracting all the SAP BO
objects to an LCMBIAR file. LeapLogic requires Universe, Webi reports as well as crystal reports to
perform an effective assessment.

Additionally, this document provides detailed instructions for saving individual SAP BO Universe and
web intelligence reports.

2. Deploying LeaplLogic Utility in Customer Environment — Prerequisites
(Preferred Approach)

This approach helps to deploy LeapLogic utility in the customer’s environment. It helps to extract
the complete SAP BO metadata. This is a preferred approach as it extracts and assesses all the SAP
BO artifacts in one go without any hassles or iterations.

SAP BusinessObjects is a comprehensive suite for analyzing business data, reporting, data
visualization, and more. SAP BO comprises metadata objects that facilitate analysis and present data
in a non-technical language.

See the prerequisites below to run the application on your system.
1. You must have Admin rights on the required machine within the SAP BO environment.
2. Java Development Kit (JDK) 1.8 should be installed on that machine.

3. Download and install SAP BO Client tools 4.1 from the SAP marketplace.

Once these prerequisites are met, Leaplogic executes an extensive Java-based utility that extracts
the required metadata from Universe and Webi reports. It follows the below given approach to
extract SAP BO metadata.

1. Update the configuration with the details of the respective SAP BO environment.
2. Execute the utility via the command prompt which:

o Extracts metadata of Universes with the help of SAP BO client tools SDK.
o Extracts metadata of Web Intelligence (Webi) reports.

o Cleans and formats the extracted data and creates a set of reports.
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3. Extraction for Assessment in Impetus Environment (Alternate Approach)

3.1. SAP BO Objects Extraction
SAP BO Objects comprises of all the artifacts required for end-to-end assessment including Universe,
Webi reports as well as crystal reports. Follow the steps below to save the SAP BO objects from a
live CMS to an LCMBIAR file.

1.

2.

Launch the Promotion Management tool and create a new job.
In the Source section, enter the following information.

o CMS Name

o User

o Password

o Authentication

From the Destination drop-down list, select Output to LCMBIAR file option and click Create.

Click Add Objects to add info objects to the job. You can use the Manage Dependencies option
to manage the dependencies of the selected job.

To encrypt the LCMBIAR file using password, select Password Encryption checkbox. If you
encrypt the LCMBIAR file, the promotion process takes a little more time (Optional)

o Enter a password in the Password field.
o Re-enter the password in the Verify Password field.

Click Promote.
The Promote window will be displayed.
Modify the security options as required and click Export.

The LCMBIAR file will be created. You can save the LCMBIAR file on your local file system.

Note: This is the recommended way to export the SAP BO Objects artifacts as it exports all the
objects (Universe, Webi reports, and crystal reports) in one go. This enables furnishing rich inputs
for Leaplogic assessment and hence create more profound insights.
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3.2. Universe Extraction
SAP BusinessObjects is a comprehensive suite for analyzing business data, reporting, data
visualization, and more. SAP BO Universe comprises metadata objects that facilitate analysis and
present data in a non-technical language.

Follow the steps below to save the universe for all users.
1. Open the Universe in IDT/UDT.
2. Right click the Universe listed in the Repository Resources View that you want to retrieve.

3. Select Retrieve Universe.

]
(|

) Repository Resources &3 ‘

*v 78, B X
v o] @BOBJ4:6400 (Administrator - Enterprise)
» [ Connections
] Sets
~ ] Universes
v [ ] Bl Platform Auditing
. Bl Platform Audit Analysis.unx
4 Blplatfi (g Check Integrity
» [ Samples

@
o

Run Query
Create Set Containers...
Retrieve Universe

Create Linked Universe

Rename Universe
Lock Universe
Delete Universe

Copy Object Path

@ X B 2EMRE '

4. Select the Save for all users (unsecure files) checkbox.

__D-Saﬂfforall users (unsecure files) m

[]Lock Universe

If any warning or error persists, follow the steps mentioned in the Configuring Shared
Connections section.
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3.2.1. Configuring Shared Connections
To make the universe available for all users, you need to save the universe using an unsecured
connection. Follow the below steps to configure a new shared connection for your universe.

1. Login to the Universe Design Tool.

User Identification X
SAD4

Enter your name and password to log in.

Bt [so834 |

User Name: | Administrator

Password: I [

Authentication |Enterprise |
— ok | cancel Hep |

2. To create a new shared connection, click Tools > Connections.

3¢ Universe Design Tool

| Bl Eit View Insert| Tooks
SN R R conrecions. IEEEEEEE] =
(@ @] B b Bilv @8]

I SRV 3 Lists of Values...

Agaregate Nayigatior. .
List of Aliases. .
[0l List of Derived Tables...

Query Panel

Automated Detection
£ Check Integrity...

Login As...
Change Password. ..

Manage security. ..

Options...

3. Click the New Connection icon in the Connection Panel to create a new connection.
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3 Universe Design Tool

| Fle Edit View Insert Tools Window belp

DSHSB|lto@man 9B EY B E®E] =
EEREC IR TR T ]
P X v R

<k Connection Panel

[wla]| o|a|x| *|wl@|l v|m &)

ew Connection| | Ty Network La;

3 BI piatform CMS system d.

7 CustomerxvL XML Files
T OrdersxML XML Files
T ProductxmL XML Files

T Rio2016 5Qlite

/
B Test_Unsecure Sybase SQL Anywhere 16 Shared Connections
13 efashion-nebi 5Qlite

4. Select Shared from the Connection Type dropdown and provide a connection name. Then, click
Next.

Setting the connection type to Shared ensures that all users can access the data.

FF Universe Design Tool

| Ele Edit View Insert Tools Window Help
‘DeSHd|SRlseEAR 9 |RIEY B EHES] |
B Ve bR HiCEHE T VIES]

X v oA

& Connection Panel

+3 Define a new connection

Connection Type [ atabase engne [ Foider

Sybase SQL Anywhere 36 /Bl Platform Auditing
Name SAP B1 platform CMS syste... /B Platform Auditing
Gz XML Fles 1

XML Files !
XML Files !
SQlite

Connection Folder

!
Connection Description Sybase SQL Anywhere 16 Shared Connections
SQiite !

5. Select the driver according to your requirements and click Next.
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3 Universe Design Tool

| Bl Edt View Insert Tools Window Help

DSHsSalJEa% 9B EYBIEFE] = |

R IE TR X1

PX v R

<k Connection Panel

+3 Define a new connection

| Database Engine | Folder

Sybase SQL Anywhere 16 fBI Platform Auditing
SAP Bl platform CMS syste... /Bl Platform Auditing
HML Flles li
ML Flles li
XML Files i
SQlite !
Sybase SQL Anywhere 16 Shared Connections.
sQlit= li

BusinessObjects OpenComn...  Text Files
BusinessObjects OpenComn...  Google BigQuery
JDEC Drivers Goagle BigQuery
PR Tvare (iracla Bl

[~ Fiter stored procedure network layer

< Back

6. Provide configuration details according to your requirements and click Next.

FF Universe Design Tool

| Fle Edit View Insert Tools Window Help

DSHISE| 4 E®B IR EVBIEBEL |
Y v bEBRIMISEET V88|

(X A

=k Connection Panel

3 Define 2 new connection

| Database Engine [ Folder

Sybase SQL Anywhere 15 [BI Platform Auditing
SAP BI platform CMS syste... /Bl Platform Auditing
¥ML Flles li

T XML Files !
XML Files li

Use existing data source: g sQlite !
Sybase SQL Anywhere 16 Shared Cornections.
Data Source Name sQite /

Use connection string

Driver

c fon Sting

This creates a new shared connection. Now, you need to configure this shared connection to

your universe.
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S Universe Design Tool - X

| Bl Edt View Insert Tools Window Help

DSHsSalJEa% 9B EYBIEFE] = |

MY r9 hAaDRHMEeHE T ¥ 8|
X v A

<k Connection Panel

+3 Define a new connection

| Folder
Sybase SQL Anynhere 16 fBI Platform Auditing
SAP B platform CMS syste...  /BI Flatform Auditing
XML Files !
XML Files /
XML Files i
SQlite /
Sybase SQL Anywhere 16 Shared Connections.
sQite /

7. Go to your Universe and configure the created shared connection. Click Open.

3¢ Universe Design Tool - b

i [Ele edt view mnsert Toos window kelp
EEEENNERERNEE] o |
v AN Wl
\

=[] save
Save As..

Save Al

Parameters...

Page Setup...

[ print Preview...
5 print...

1Universi-secure

2Universifor RAC-unsecureattempt2
3Universifor RAC

4Universifor RAC-Unsecure

Exit

8. Browse the file and click Open.

3¢ Universe Design Tool - ®

i Fle Edt View Insert Toos Window el

DSH| SR+ EAR 9 R EYBEEE |
EERCIFEF-FIE T - T EIEAr Y 1

EXEA

< Open

Lookin: | || webi - B o B

~
[ name Date modified

@l 1sland Resorts Marketing-unsecure 1 4/3/2024 1:20PM
@ |Universtfor_RAC- unsecureattempt2 4/9/2024 1:28 PM
@ lUniverstfor RAC 4/9/2024 1:21PM
&

3 |Univers tfor_RAC-Unsecure 4/3/2024 1:22PM
| Univers1-secure 4/5/2024 1:46 PM

< I

Fiename:  [Universisecure

Fies of type: [BusinessCbjects Universes (*.unv)

I” Open as read-only
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9. Click File > Parameters.

§F Universe Design Tool - Univers1 - [Administrator - @BOBJ4:6400] - [Univers1]

10. Select the created shared connection and Click OK. For instance,

Universe is the shared connection created as an example.

$F Universe Design Tool - Univers] - [Administrator - @BOBIM:6400] - [Univers1]

- X
D[ Fle Edit Vew Insert ook Window Help _l& x|
(0 e cui4n EEEEREEEEE j|
{ | e sl R X )
1 Cose Chrl+w
X
g
Save Col4S Lo icATION TYPESTR =
M Savels. F12  fonTypetD
B
=zt Hon_Tye_Name
Import...
Export...
&) parameters....
Page Setup...
[ Print Preview...
3 print... Cirl4p
1Univers1-secure
2Universifor RAC-unsecureattempt2
3Univers1for_RAC
4Universifor RAC-Unsecure
Exit

in the screenshot below, Test

:Bg He Edit View Insert Took Window Help

DSHISR/REHAN% 9 R B4 B[EE [ |
‘BY 9 hkbh M HE ¥ 88|

X

x| || ADS_APPLICATION TYPE STR

[pplication_Type_ID
nguage
|appiication_Type_Name

Universe Parameters

The following information identifies the universe. A Lniverse is defined by its
name and database connection:

Defiition |5ummary| Strategies | Controis | SQL | Links | Parameter

Name: | Univers1

Description:

Connection Folder:

| shared Connections

Connection: | Audit QU Anywhere

i=1]

CrdersZiML
I ProductimL
I™ Clickhere to|i#8 Rio2016

s Ll

lest

oK I Cancel | Help |

e cr @ .

11. Go to File > Save As...
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5 Universe Design Tool - Univers1 - [Administrator - @BOBI4:6400] - [Univers1]

- x
O [e Edit View Insert Tooks Window Help _l8 x|
Mew... ctrl+n WE] # R \@@ B [w0%  ~] ‘
& .. it FtivIes]
Close ctrl+w

Save Cirl+s

Save Al

Import...
Export.

Parameters...

Page Setp...
[G Print Preview..
“ennt... Ctrl+P

1Univers t-secure

2 Univers tfor_RAC- unsecureattempt2
3 Univers tfor_RAC

4 Univers tfor_RAC-Unsecure

Exit

12. Select the Save for all users checkbox.

JF Universe Design Tool - Univers1 - [Administrator - @BOBI4:6400] - [Univers1]

— X
‘Dg He Edit View Insert Took Window Help 1B x]
DS SsB|l4LEmHd 9B 4 @ |[E M 5[ ] |
mYvY bR HMEeHE Y ¥ 88|
(X A
=l ADS_APPLICATION_TYPE_STR =
[Appiication_Type_ID-
nguage:
|application_Type Mame
S Save As X
Savein: | webi - « @B er B~
Name Date modified A
Island Resorts Marketing 4/3/2024 12:33 PM
Island Resorts Marketing-Secure 4/3/2024 12:39 PM
Island Resorts Marketing-Unsecure 4/9/2024 12:38 PM
Island Resorts Marketing-unsecure 1 4/9/2024 1:20 PM
Universifor RAC 4/3/2024 1:22PM
nivers1far RAC-inesmreattamnt? 4/2/2024 1:28PM 2
< >
Fiename:  [LUniversi-secure Save |
Save as type: |Bus4nessobje:ts Universes (%.unv) LI Cancel
¥ Save for all users

e cr @ .

13. Click Save.

14. Share the exported SAP BO Universe files with the LeaplLogic team.
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3.3. Web Intelligence Reports Extraction
Web Intelligence builds reports that help you to analyze and visualize data from various sources.
Please see the steps to save a copy of the web intelligence documents.

1. Go to Web Intelligent Rich Client and open the report.

2. Select Save report from the toolbar.

¥ Save a copy of the document *
&« v <« Docume.. » My 5AP BusinessObjects Documents » v 0 Search My SAP BusinessObjec... 2
Organize - Mew folder B 0
userDocs -~ Mame Date medified Type Size
& This PC addins 4/7/2024 9:33 AM File folder
P 3D Objects | LocData 3/28/2024 %:36 AM  File folder
."?."’ N i
I Desktop templates 4/7/2024 9:33 AM File folder
. | userDocs 4/9/2024 4:23 AM File folder
Documents ) )
userlibs 4/7/2024 9:33 AM File folder
& Downloads P r— 4/7/20249:33AM  File folder
J'J Music
&= Pictures
B Vvideos
am Local Disk (C:)
LN 4 >
File name: | Bl on Bl - Scheduling - Copy] V|
Save as type: |Weh Intelligence Document w |
A Hide Folders Save | | Cancel |

3. A warning window appears. Click Remove Security.

A Warning

The document you want to copy is secured. Pick one of these options:

- Remove original security
- Apply security to you only
- Keep source document security

Remove Security  Secure For Me Keep Security
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3.4. Uploading Extracted Artifacts in Impetus Environment
Once we receive the artifacts from the customer, use these steps to upload/place them within the
Impetus environment to further carry out the required assessment.

1. If universe is in the .unx format convert it to .unv using the IDT tool.

2. Open the universe file in the IDT tool.

3. Publish the connection first.

4. Change connection of universe in the IDT tool with the published connection.
5. Delete the previous connection.

6. Publish universe to desired file location in the SAP BO repository.

7. Publish the SAP BO report to the SAP BO repository.
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4.  Getting Help

Contact Leaplogic technical support at info@leaplogic.io
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